SME Server 11.0 Development
The Koozali SME Server project
The Koozali Foundation Inc. is a nonprofit corporation that governs the open source Koozali SME Server project. Koozali SME Server is a stable, secure and easy to use/manage linux server that provides common server functionalities out of the box. Many open source contributions are available that can extend the default server functionality making Koozali SME Server an even more powerful and flexible business server solution. Thousands of Koozali SME Severs have been deployed as real or virtual servers and in the cloud to serve many small to medium enterprises, and this number is growing day by day. The Koozali SME Server is free to use but it takes a lot of effort and money to develop, make, and maintain. We therefore ask you for your considerations.
Volunteering
Koozali Foundation Inc. together with its community hosted at https://contribs.org is a collaborative effort of volunteers. You too can contribute to the development and continuity of the Koozali SME Server project as described on our volunteering page. Everybody is welcome to join the already 4000+ member contribs.org community and can contribute with any skill set.
Financial donations
You can also show your support by making financial donations. The preferred way to make financial donations is using the donate option in the forums. You are free to choose any amount and frequency, being monthly, yearly or only once. The benefit of donating through your forums account is that your forum user name will receive a badge, showing your donation status. If you do not have a forum account, you can create one, or select the below PayPal option to make your donations.
Commercial usage
Organizations that use Koozali SME Server for their business, provide professional services related to SME Server or in any other way benefit commercially from the Koozali SME Server project, are kindly requested to consider regular financial donations that reflect their business benefits.
Koozali Foundation Inc. is happy to supply an invoice for any donations received. For more information on invoicing please send a mail to treasurer@koozali.org.
Thank you for your considerations and support!
SME Server 11
- SME Server 11 Release Notes
- SME11 Development Roadmap
- Tests of all features of SME Server 11.x (SME11_QA)
- What do you want to see in SME Server 11.X
- An overview of all related development pages
Current status
- Latest Build: SME Server 11.0 Http but if You need to build your Own Iso for Testing purpose see the Jigdo page and specially
Testing
All users are encouraged to test, see our draft quality assurance testing page for tasks SME11.0_QA.
All testing should be based on the released version.
Considerations before installing
Installing
There needs to be hardware (motherboard chipset video graphics etc) compatibility with the underlying Linux version that sme server uses.
For SME11 A1, it is based on Rocky 8.10 and all available updates To test your hardware to see if compatible with the underlying Linux version, download & install the appropriate CentOS version as listed above. If you have problems installing CentOS then you are likely to have problems installing SME server, so in that case you may need to chose more compatible hardware. Sometimes you can turn off advanced features in the BIOS as a workaround where there are limited compatibility issues, and/or disable onboard components that are known to be incompatible & use add on plug in expansion boards to perform those functions eg NIC, graphics, where suitable drivers are not available for the onboard product.
Current tasks
Current open bugs
| ID | Status | Package | Summary (199 tasks) ⇒ |
|---|---|---|---|
| 109 | CONFIRMED | smeserver-lib | /sbin/e-smith/db {get,set}prop should not allow 'type' |
| 2006 | CONFIRMED | --- | Non-ASCII characters used in passwords don't seem to work |
| 2023 | CONFIRMED | e-smith-manager | Server manager header/footer template fragments are in wrong RPM |
| 3763 | CONFIRMED | smeserver-samba | changing admin password via windows ctrl-alt-del does not also change root password |
| 3797? | CONFIRMED | smeserver-base | tryagain_page doesn't always display for admin |
| 4206 | CONFIRMED | smeserver-qpsmtpd | A uuencoded message attachment appears as garbled text in the body of a message |
| 4780 | CONFIRMED | smeserver-qpsmtpd | Valid recipient check is disabled for locally generated mail ("relayclients") |
| 5676? | CONFIRMED | smeserver-base | Bonding cannot be disabled if one NIC is disabled/removed |
| 5702 | CONFIRMED | smeserver-backup | Add a manual backup option in sme |
| 6294 | CONFIRMED | smeserver-base | Inability to change entries in Hostnames and Addresses panel (IP and FQDN) |
| 6796 | CONFIRMED | smeserver-base | hostentries do no survive change of domain |
| 6836 | CONFIRMED | smeserver-base | console backup does not cope well with multiple removable devices available [8b7] |
| 7129 | CONFIRMED | smeserver-proftpd | "proftpd: pam_env(ftp:setcred): Unable to open config file: /etc/security/pam_env.conf: No such file or directory" in "/var/log/secure" |
| 7742 | CONFIRMED | smeserver-dovecot | IMAP session continues after disable IMAP in server-manager |
| 7804 | CONFIRMED | smeserver-base | Old name cannot be removed in DNS panel after server name is changed after updating e-smith-base to version 5.2.0-79.el5.sme |
| 7805 | CONFIRMED | smeserver-base | Additional old name cannot be removed in DNS panel after updating e-smith-base to version 5.2.0-79.el5.sme |
| 7840 | CONFIRMED | smeserver-base | Cannot exit from console on tty1 when console boot set to auto mode |
| 7891 | CONFIRMED | smeserver-qpsmtpd | Email - Block Executable Content false positives when signature found in the middle of a file |
| 8008 | CONFIRMED | smeserver-apache | declare unixgroup in httpd.conf |
| 8074 | CONFIRMED | smeserver-email | SMTP to ISP Authentication timeout problem |
| 8192 | CONFIRMED | smeserver-base | Move dmount() to backup.pm |
| 8271 | CONFIRMED | smeserver-backup | Backup - selective restore fails to display files and directories on large backups |
| 8304 | CONFIRMED | smeserver-base | Console display slightly corrupted - black borders missing on two sides. [sme9b4] |
| 8420 | CONFIRMED | smeserver-base | Local Networks - Delete Form - "Abbrechen" Button does not work correct |
| 8945 | CONFIRMED | smeserver-manager | NFR: present option to set forward or adjust wording on Locked account screen |
| 9058 | CONFIRMED | smeserver-samba | Oplock break failed for file USER.V5/NTUSER.DAT |
| 9273 | CONFIRMED | smeserver-spamassassin | TextCat spamassassin plugin not loaded in the correct file |
| 9426 | CONFIRMED | smeserver-base | warning in messages logs and on screen when running ippp |
| 9431 | CONFIRMED | smeserver-base | error running bootstrap-console |
| 9656 | CONFIRMED | smeserver-qpsmtpd | Return 4XX in case of DNS timeout while fetching dkim policies |
| 9696 | CONFIRMED | --- | update link http://www.contribs.org/development/ |
| 9805 | CONFIRMED | smeserver-qpsmtpd | Failure in DMARC report sending overnight |
| 9906 | CONFIRMED | smeserver-qpsmtpd | Rejected DMARC emails are tried every night, and never deleted? |
| 10090 | CONFIRMED | smeserver-email | modify SM email panel wording to make spamassassin setting clearer |
| 10103 | CONFIRMED | perl-Mail-DMARC | DMARC sql error in qpsmtpd log |
| 10233 | CONFIRMED | smeserver-backup | restore from console will not restore mysql db |
| 10285 | CONFIRMED | smeserver-base | Prevent entering invalid netmask |
| 10497 | CONFIRMED | qpsmtpd | qpsmtpd plugin typo in HELO log report |
| 10550 | CONFIRMED | smeserver-lib | NFR password generator |
| 10570 | CONFIRMED | smeserver-base | remove key StatusReports from config db |
| 10643 | CONFIRMED | --- | Error: IP cannot be server IP or Gateway IP. |
| 10778 | CONFIRMED | smeserver-qpsmtpd | 554 Message not allowed - [299] on yahoo server after enabling disclaimer |
| 10835 | CONFIRMED | smeserver-devtools | .gitignore... |
| 10845 | CONFIRMED | smeserver-base | post-upgrade : Use of uninitialized value $nt_hash in string eq at /etc/e-smith/events/post-upgrade/S15user-lock-passwd |
| 10953 | CONFIRMED | anaconda | disable and hide addons in gui install |
| 10977 | CONFIRMED | smeserver-manager | Make remoteaccess.pm also validate the subnet octets - make change for Server-Manager2 |
| 11085 | CONFIRMED | smeserver-certificates | improve integration of certificate with dehydrated using a dedicated domain |
| 11235 | CONFIRMED | --- | config memory / number convert sanitizer |
| 11271 | CONFIRMED | smeserver-mysql | Changing host.domain does not update Host in mysql database |
| 11400 | CONFIRMED | smeserver-php | ease php change for contribs |
| 11419 | CONFIRMED | smeserver-radiusd | remove pptpd references |
| 11427 | CONFIRMED | smeserver-php | allow set timeout |
| 11444 | CONFIRMED | smeserver-php | ibay customisation: merge SSL option |
| 11534 | CONFIRMED | smeserver-radiusd | difference between domain events |
| 11540 | CONFIRMED | perl-Apache-AuthTkt | cookie without SameSite property |
| 11560 | CONFIRMED | smeserver-grub | update-grub action runt by local on every reboot |
| 11614 | CONFIRMED | smeserver-certificates | NFR : check if custom cert and key are related and default to self signed if not |
| 11615 | CONFIRMED | smeserver-apache | NFR : httpd check if custom cert and key are related and default to self signed if not |
| 11616 | CONFIRMED | smeserver-proftpd | NFR : proftpd check if custom cert and key are related and default to self signed if not |
| 11689 | CONFIRMED | smeserver-base | Allow comment for Remote Access panel, Remote Management table |
| 11797 | CONFIRMED | perl-Email-Sender | First Import to SME perl-Email-Sender-1.300036 |
| 11810 | CONFIRMED | smeserver-manager | License panel is left truncated, does not flow. |
| 11884 | CONFIRMED | smeserver-backup | desync of /etc/shadow - /etc/passwd /etc/group /etc/gshadow |
| 11900 | CONFIRMED | smeserver-mysql | check use of /sbin/e-smith/mysql-preload |
| 11935 | CONFIRMED | --- | oauth soon mandatory to fetch from gmail accounts |
| 12099 | CONFIRMED | smeserver-openssh | Increase MaxAuthTries for sshd |
| 12110 | CONFIRMED | smeserver-manager | untainting printers server-manager2 |
| 12156 | CONFIRMED | smeserver-backup | log user to remove as they have no more use and missing their home |
| 12270 | CONFIRMED | smeserver-roundcube | NFR: Allow the specification of the host for the imap mail |
| 12302 | CONFIRMED | smeserver-php | NFR allow admin customization of ibays php fpm pool |
| 12312 | CONFIRMED | smeserver-clamav | Extraneous database update values in clamav and freshclam |
| 12320 | CONFIRMED | smeserver-ibays | Add functions to e-smith-ibays for webapps |
| 12321 | CONFIRMED | smeserver-ibays | Create a new action to set permissions for an ibay based on dbase parameters and pre-set settings |
| 12322 | CONFIRMED | smeserver-ibays | Breakout setting ownership/permissions for ./files and ./html into a separate action |
| 12377 | CONFIRMED | smeserver-mock | BogusDateBot.sh not handling multiple spaces within data |
| 12433 | CONFIRMED | smeserver-backup | upon restore keep user id entry from supported services |
| 12446 | CONFIRMED | smeserver-manager | Welcome screen - After login timeout - fails to show translated message |
| 12513 | CONFIRMED | ipsvd | evaluate to retire ipsvd (required by smesevrer-qpsmtpd and smeserver-tftp-server) |
| 12566 | CONFIRMED | daemontools | seek alternative to daemontools-encore 1.10-2 / daemontools 0.76 |
| 12578 | CONFIRMED | multiple-packages | Make sure all SMEServer packages that we re-build reference the correct license. |
| 12580 | CONFIRMED | --- | Update any other reference to e-smith-.*-update to smeserver |
| 12587 | CONFIRMED | smeserver-roundcube | composer installs skins in plugins folder |
| 12604 | CONFIRMED | --- | audit error augenrules[730]: failure 1 |
| 12667 | CONFIRMED | smeserver-manager | Workstation restore from a removeable device fails |
| 12692 | CONFIRMED | smeserver-base | use same wording for user action script |
| 12696 | CONFIRMED | smeserver-manager | Uncaught File 'Roboto-Regular.ttf' not found in virtual file system |
| 12699 | CONFIRMED | smeserver-manager | SM2 Re-configure and Reboot not translated |
| 12704 | CONFIRMED | smeserver-locale | Hebrew translation only has "Date and Time" panel translated. |
| 12713 | CONFIRMED | smeserver-locale | Update smeserver-manager.locale with po files (for weblate import) |
| 12716 | CONFIRMED | smeserver-update | alert after EOL if upstream release is not up to date |
| 12728 | CONFIRMED | smeserver-update | Warning for signal-event post-upgrade; signal-event reboot scrolls off screen. |
| 12734 | CONFIRMED | smeserver-mysql | MariaDB config setting table_definition_cache |
| 12752 | CONFIRMED | smeserver-manager | NFR Server-manager - Add DHCP Wake On LAN links in hostnames panel |
| 12768 | CONFIRMED | smeserver-base | userdel: user is currently used by process |
| 12772 | CONFIRMED | smeserver-lib | Move network functions from util.pm to util/network.pm |
| 12862 | CONFIRMED | mini-qmail | Cleanup qmail users |
| 12879 | CONFIRMED | smeserver-dovecot | NFR define default folder |
| 12903 | CONFIRMED | smeserver-manager | The jDatatable tables do not reflect the current locale in terms of language etc. Only show English |
| 12904 | CONFIRMED | smeserver-manager | NFR paste ssh key in smanager Remote Access Panel |
| 12911 | CONFIRMED | anaconda | patch anaconda to change default partitionning |
- Report truncated - count greater than max allowed 101 > 100
Verifications
| ID | Package | Summary (26 tasks) ⇒ |
|---|---|---|
| 9844 | smeserver-manager | User-password gives misleading error on entering same password |
| 11708 | smeserver-manager | CSRF security check should fully protect smeserver-manager |
| 12677 | smeserver-base | add support for external VLAN |
| 12678 | smeserver-base | rework pppoe for kernel space rather than use rspace |
| 13074 | smeserver-base | /usr/sbin/pppd: /usr/lib64/pppd/2.4.5/rp-pppoe.so: cannot open shared object file |
| 13130 | smeserver-base | pppoe fails to recconect after update: interface or tty missing |
| 13307 | smeserver-manager | Update to email settings for peer port mean't I lost my 3rd party mail server hostname |
| 13449 | smeserver-manager | Set CSS so that fields in a form extend to the right with a max of 50%, but auto sized within that. |
| 13505 | smeserver-update | smeserver-update: remove old server-manager panels |
| 13592 | smeserver-certificates | Letsencrypt fails to create genuine cert when test certs have been generated |
| 13634 | smeserver-manager | dnf panel : detect if something is already running and display it |
| 13652 | smeserver-manager | Backup.pm controller does load directories to backup only at smanager start |
| 13653 | smeserver-lib | servicecontrole should superseed to reload-or-restart any restart smanager |
| 13681 | smeserver-manager | pm files are not updated when we add new lex files translation |
| 13684 | smeserver-base | encoding issue in /etc/e-smith/events/actions/user-modify-unix and /etc/e-smith/events/actions/user-create-unix |
| 13686 | smeserver-manager | Re-factor any set of tests where the subsequent test is still run when the previous one has failed |
| 13689 | smeserver-manager | my ($notif, $modul) = ; Does NOT intialise BOTH variables |
| 13691 | smeserver-manager | Scan of Controller files found a few typos etc |
| 13701 | smeserver-lib | Cannot add user to ldap |
| 13704 | smeserver-ldap | migrate missing values |
| 13705 | smeserver-manager | Overall bug to document changes needed to accomodate a new translation system |
| 13711 | smeserver-manager-locale | Make install remove smeserver-manager-locale-<langCode> packages when installing the new smeserver-manager-locale |
| 13713 | smeserver-manager | DNF panel start button hit fails with no CSRF token found |
| 13714 | smeserver-manager | When login timeout expires, arrange that the current panel is re-entered once re-login is successfull |
| 13716 | smeserver-manager | Keeping both the AuthTKT timeout and the smanager[Timeout} properties is a potential exploit |
| 13718 | smeserver-certificates | Extra chars in Letsencrypt menu entry - Need perl module Locale-Maketext-Lexicon |
Verified
| ID | Package | Summary (38 tasks) ⇒ |
|---|---|---|
| 12218 | smeserver-base | self-signed certificate renews every 24hrs with ' (apostrophe) in ldap field |
| 12428 | smeserver-manager | SM2 Login button does not highlight when you press it. - default Theme |
| 12669 | smeserver-manager | After using dnf to update and reboot, unable to login to SM1 |
| 12951 | smeserver-manager | Mail log analysis panel needs re-write for Postfix. |
| 12989 | smeserver-manager | Workstation Restore when reboot is selected when offered SM2 errros to a Proxy Error screen and fails to reboot |
| 13450 | smeserver-manager | user password panel - after an error password description reverts to lex string |
| 13488 | smeserver-qpsmtpd | allow enabling only private authentication for qpsmtpd / port 25 |
| 13574 | smeserver-manager | NutUPS - Misssing entry in lex file |
| 13581 | smeserver-certificates | Letsencrypt check&enable stops parsing at dash |
| 13583 | smeserver-certificates | Revert Cert to self signed fails when called from SM2 panel |
| 13586 | smeserver-manager | Viewlogfiles horizontal scroll bar is only visible at the bottom |
| 13588 | smeserver-certificates | LE panel unresponsive without internet |
| 13600 | smeserver-postfix | Syntax errors in postfix files |
| 13604 | smeserver-dovecot | AdminIsMaster not working when SharedMailbox and ACL is also enabled |
| 13613 | smeserver-mysql | mariadb-initialize should not test on /var/lib/mysql/mysql/user.frm |
| 13615 | smeserver-certificates | getmyip not overriden by letsencrypt{ExternalIP} set |
| 13619 | smeserver-openssh | WARNING: UNPROTECTED PRIVATE KEY FILE! |
| 13620 | smeserver-manager | Change admin password in Smanager throws an error |
| 13636 | smeserver-nutUPS | nut french |
| 13639 | smeserver-manager | Make sure all calls to the Accounts DB routines include the UTF8 |
| 13658 | smeserver-locale | need to translate FRAMES_SMANAGER |
| 13659 | smeserver-manager | Remote Management multi delete fails |
| 13661 | smeserver-manager | localize "please wait" on the submit buttons |
| 13663 | smeserver-manager | /usr/share/smanager/lib/SrvMngr/Controller/*.pm using non utf8 db |
| 13665 | smeserver-certificates | smeserver-certificates still missing UTF8 in DB opening calls |
| 13675 | smeserver-manager | Adding domain with wide chars makes the self signed certificate unacceptable to Chromium. |
| 13676 | smeserver-manager | Quota panel:"Can't locate object method "localise" Error message when opening quota panel |
| 13679 | smeserver-manager | not redirect to current panel after authorization check |
| 13680 | smeserver-manager | increase timeout before auto logout |
| 13682 | smeserver-manager | Wide character should be refused from username/group/ibay (but accepted in description/firstname/lastname..) |
| 13687 | smeserver-spamassassin | wbl from and to lists |
| 13690 | smeserver-manager | Change e-mail access settings POP3 changes not being accepted on save remains as Enabled for local access only |
| 13692 | smeserver-manager | when creating or modifying user, the check for duplicate pseudonym does not lowercase the first and last names. |
| 13695 | smeserver-manager | datetime panel: Time server test call needs csrf token |
| 13696 | smeserver-manager | Email settings panel: DB Settings for email reception not set correctly |
| 13697 | smeserver-lib | creating or modifying user error Wide character in getpwnam at /usr/share/perl5/vendor_perl/esmith/AccountsDB.pm line 492. |
| 13702 | smeserver-manager | ldap directory /useraccount : company compartment city and phone should be mandatory |
| 13719 | smeserver-update | Need perl-YAML module enabled |
Closed
| ID | Package | Summary (768 tasks) ⇒ |
|---|---|---|
| 131 | smeserver-apache | [ 1323823 ] RSA server certificate CommonName (CN) does NOT match... |
| 931 | smeserver-proftpd | NFR: ftp Anonymous should be disabled by default |
| 2269 | smeserver-apache | Load apache mod_dav module by default |
| 5382 | smeserver-base | Hostnames/addresses panel doesn't reject same IP with different mac |
| 6278 | smeserver-manager | Update server-manager to current web standards and to conform to CSP rules |
| 6453 | smeserver-base | remove use_authtok from pam config when ldap auth is enabled |
| 6510 | smeserver-qpsmtpd | Allow port 587 to be used as mail submission port (ESMTP with authentication) |
| 6819 | smeserver-packetfilter | Port 25 closed after Server gateway switched to server, then back to gateway |
| 7463 | e-smith-manager | HeadingWeight Wrong in Server Panel navigation scripts |
| 7490 | smeserver-certificates | SSL-certificate panel |
| 7819 | perl-Mojolicious | New Server-Manager Framework, Mojolicious |
| 7914? | smeserver-proftpd | Correct proftpd.conf template(40IBayAccess). |
| 7915 | smeserver-proftpd | New ibay's directory loses SGID flag then created via ftp. |
| 7946? | qmail | qmail shoud ignore CNAME resolve failures |
| 8185 | smeserver-certificates | Provide server-manager GUI for generating a CSR, and for uploading a signed certificate set. |
| 8207 | smeserver-qmail | Error 454+451 in qmail log while trying to send mail trough ISP server |
| 8268 | smeserver-base | Remove primary (all lower case) from defaults and accounts database |
| 8275 | smeserver-lib | no console page uses whiptail |
| 8309 | smeserver-manager | Add ipt_recent sshd autoblocking to e-smith-openssh - additional note in server-manager |
| 8376 | smeserver-proftpd | proftpd: Can I disable Anonymous logins |
| 8477 | smeserver-manager | smtp-auth-proxy PeerPort should be configurable |
| 8676 | smeserver-certificates | Integration of EFF free certificates |
| 9196 | smeserver-certificates | Server manager panel for the letsencrypt |
| 9492 | smeserver-qpsmtpd | Remove unused config for qmail-smtpd |
| 9566 | e-smith-manager | Server-Manager uses unsafe-inline scripts/stylesheets <-> Strong Content-Security-Policy on VirtualHosts |
| 9567 | smeserver-apache | Template for Content-Security-Policy on VirtualHosts |
| 9586 | --- | Move Mitel copyright notices to copyright and licenses page |
| 9751 | samba | Rebuild Samba-4.18.6-3 Upstream Package with Domain Controller Support |
| 10307 | smeserver-email | JunkMail - some messages end ups in JunkMail folder despite "Sort spam into junkman folder" = Disabled |
| 10336 | --- | plymouth screen on first boot display linux centos 7 |
| 10440 | smeserver-postfix | email to pseudonyms pointing to another pseudonym fails when they are another full email |
| 10725 | smeserver-manager | error logged on backup panel |
| 10738 | qpsmtpd | qpsmtpd logging corruption |
| 10779 | smeserver-spamassassin | qpsmtpd "Unable to scan for viruses" after creating custom rules for local.cf |
| 10847 | smeserver-ldap | ibay-modify failed to modify entry |
| 10933 | qpsmtpd | TLS error give an empty line |
| 10935 | smeserver-dovecot | dovecot should use ssl_dh=</path/to/dh.pem instead of ssl_dh_parameters_length |
| 10954 | anaconda | create and fill help KoozaliPlaceholder.html and KoozaliPlaceholderWithLinks.html |
| 10976 | smeserver-manager | Make localnetworks.pm validate the subnet octets for Server- manager2 |
| 11185 | smeserver-manager | New version for smeserver-manager |
| 11367 | --- | change type from service to configuration |
| 11380 | smeserver-devtools | brb and python for genfilelist |
| 11416 | smeserver-test | remove pptpd references |
| 11417 | smeserver-lib | remove pptpd references |
| 11418 | smeserver-hosts | remove pptpd references |
| 11476 | smeserver-php | Edit spelling and confirm db prop name ibay.conf and 20Horde |
| 11478 | smeserver-audittools | Configuration report (under Server Manager/Report a bug) Includes some parts of the standard install |
| 11671 | smeserver-qpsmtpd | Files and folders in /var/spool/qpsmtpd are not being cleaned up |
| 11733 | smeserver-dovecot | Dovecot quota-fs error |
| 11772 | smeserver-base | ssl.pm does not handle elliptic curve certificates |
| 11780 | smeserver-manager | Add in dummy classes to div in each ep file for future themes |
| 11793 | smeserver-manager | For smeserver-manager - add module class to div id="module" |
| 11802 | qpsmtpd | Update qpsmtpd to latest from git |
| 11809 | smeserver-manager | Lack of a space after full stop and comma in English version of Server Manager2 panel descriptions in some places. |
| 11815 | smeserver-manager | Bring Group add and update panels into line with others |
| 11821 | smeserver-manager | Mail log file analysis shows blank |
| 11822 | smeserver-manager | In Review Configuration virtual domains not aligned. |
| 11823 | smeserver-manager | In Review Configuration - IP address not show correctly for Server Gateway |
| 11824 | smeserver-manager | User and Hostnames list does not act responsivly as window is made smaller |
| 11825 | smeserver-manager | Review configuration panel - In Server-Gateway, External IP and DHCP range not properly displayed |
| 11830 | smeserver-manager | Update Datetime and reboot ep files to help AdminLTE |
| 11846 | smeserver-manager | Warning from Browser when jquery loaded - unable to find .map file |
| 11856 | smeserver-mysql | Upgrade MariaDB to 10.x |
| 11906 | smeserver-manager-AdminLTE | Sort out spacing in menu when small fonts selected |
| 12111 | smeserver-manager | untainting server-manager2 |
| 12113 | smeserver-update | update smeserver.py plugin to be dnf compatible |
| 12114 | smeserver-update | update yum to dnf and modules |
| 12144 | smeserver-dovecot | Updating dovecot-extras overwrites existing sharedmailbox.db |
| 12149 | smeserver-base | error opening /var/log/php/php/error.log |
| 12150 | smeserver-dovecot | NFR: use INDEXPVT instead of INDEX for shared mailboxes (per-user \Seen flags) |
| 12180 | --- | IPv6 Support |
| 12211 | smeserver-lib | template-begin-ini should be in e-smith-lib not smeserver-php |
| 12245 | smeserver-manager-AdminLTE | Menu formatting with Server Manager 2 and AdminLTE |
| 12265 | smeserver-dovecot | update sieve /spam script |
| 12280 | --- | no matching host key type found. Their offer: ssh-dss,ssh-rsa |
| 12338 | --- | Bug to cover the move from CVS to Git |
| 12359 | --- | Rename all baseos e-smith* packages to smeserver* |
| 12360 | smeserver-apache | Change all references to httpd-e-smith to httpd-smeserver |
| 12369 | smeserver | Remove e-smith package? |
| 12382 | smeserver-formmagick | password requirement is different in panel and from samba |
| 12383 | smeserver-lib | increase password size requirement from 6 to 12-14 and make it configurable |
| 12384 | smeserver-lib | allow more granularity in the content of password |
| 12387 | smeserver-manager | Server Manager 2 should open unconverted contribs/panels in the current page, possibly within an iframe |
| 12396 | cvm | obsolete cvm-unix |
| 12400 | smeserver-manager | adapt last update for yum panel to smanager |
| 12423 | smeserver-mock | build proof of concept |
| 12424 | --- | list of rpm in smeos for 10 that will probably need build for sme 11 |
| 12430 | smeserver-php | default setting for serialize_precision in PHP 7.1 and higher is incorrect |
| 12442 | smeserver-manager | Default theme for SM2 submit button does not reflect hover or click |
| 12444 | smeserver-manager | Proxy Error following software update |
| 12451 | smeserver-qpsmtpd | separate qpsmtpd sqpsmtpd and uqpsmtpd configurations |
| 12454 | smeserver-proftpd | Missing PassivePorts fragment |
| 12457 | smeserver-manager | Experiment with making tables sortable and filterable and paged - using jquery. |
| 12458 | smeserver-manager | Update SM2 to use jquery plugin dataTable for tables |
| 12459 | smeserver-manager-jquery | Create rpm - smeserver-manager-jquery |
| 12464 | smeserver-manager | Server Manager 2 needs to save and restore menu organisation |
| 12465 | smeserver-manager-jquery | Update smeserver-manager-jsquery to fix left alignment of tables |
| 12466 | smeserver-manager | Add export buttons to tables in SM2 default theme. |
| 12467 | smeserver-manager-jquery | Icon not shown when second page selected on dataTable table |
| 12471 | smeserver-manager | SM2 email-filtering spam settings display or change incorrectly |
- Report truncated - count greater than max allowed 101 > 100