SME Server 11.0 Development

From SME Server
Jump to navigationJump to search


The Koozali SME Server project

The Koozali Foundation Inc. is a nonprofit corporation that governs the open source Koozali SME Server project. Koozali SME Server is a stable, secure and easy to use/manage linux server that provides common server functionalities out of the box. Many open source contributions are available that can extend the default server functionality making Koozali SME Server an even more powerful and flexible business server solution. Thousands of Koozali SME Severs have been deployed as real or virtual servers and in the cloud to serve many small to medium enterprises, and this number is growing day by day. The Koozali SME Server is free to use but it takes a lot of effort and money to develop, make, and maintain. We therefore ask you for your considerations.

Volunteering

Koozali Foundation Inc. together with its community hosted at https://contribs.org is a collaborative effort of volunteers. You too can contribute to the development and continuity of the Koozali SME Server project as described on our volunteering page. Everybody is welcome to join the already 4000+ member contribs.org community and can contribute with any skill set.

Financial donations

You can also show your support by making financial donations. The preferred way to make financial donations is using the donate option in the forums. You are free to choose any amount and frequency, being monthly, yearly or only once. The benefit of donating through your forums account is that your forum user name will receive a badge, showing your donation status. If you do not have a forum account, you can create one, or select the below PayPal option to make your donations.

Commercial usage

Organizations that use Koozali SME Server for their business, provide professional services related to SME Server or in any other way benefit commercially from the Koozali SME Server project, are kindly requested to consider regular financial donations that reflect their business benefits.

Koozali Foundation Inc. is happy to supply an invoice for any donations received. For more information on invoicing please send a mail to treasurer@koozali.org.

Thank you for your considerations and support!

Information.png Tip:
For a complete overview of SME Server Development see our SME Server Development Framework page.


SME Server 11

Current status

  • Latest Build: SME Server 11.0 Http but if You need to build your Own Iso for Testing purpose see the Jigdo page and specially

this one

Testing

All users are encouraged to test, see our draft quality assurance testing page for tasks SME11.0_QA.

All testing should be based on the released version.

Considerations before installing

Installing

[Hardware requirements]

There needs to be hardware (motherboard chipset video graphics etc) compatibility with the underlying Linux version that sme server uses.

For SME11 A1, it is based on Rocky 8.10 and all available updates To test your hardware to see if compatible with the underlying Linux version, download & install the appropriate CentOS version as listed above. If you have problems installing CentOS then you are likely to have problems installing SME server, so in that case you may need to chose more compatible hardware. Sometimes you can turn off advanced features in the BIOS as a workaround where there are limited compatibility issues, and/or disable onboard components that are known to be incompatible & use add on plug in expansion boards to perform those functions eg NIC, graphics, where suitable drivers are not available for the onboard product.

[Installation procedure]

Current tasks

Current open bugs

IDStatusPackageSummary (199 tasks)
109CONFIRMEDsmeserver-lib/sbin/e-smith/db {get,set}prop should not allow 'type'
2006CONFIRMED---Non-ASCII characters used in passwords don't seem to work
2023CONFIRMEDe-smith-managerServer manager header/footer template fragments are in wrong RPM
3763CONFIRMEDsmeserver-sambachanging admin password via windows ctrl-alt-del does not also change root password
3797?CONFIRMEDsmeserver-basetryagain_page doesn't always display for admin
4206CONFIRMEDsmeserver-qpsmtpdA uuencoded message attachment appears as garbled text in the body of a message
4780CONFIRMEDsmeserver-qpsmtpdValid recipient check is disabled for locally generated mail ("relayclients")
5676?CONFIRMEDsmeserver-baseBonding cannot be disabled if one NIC is disabled/removed
5702CONFIRMEDsmeserver-backupAdd a manual backup option in sme
6294CONFIRMEDsmeserver-baseInability to change entries in Hostnames and Addresses panel (IP and FQDN)
6796CONFIRMEDsmeserver-basehostentries do no survive change of domain
6836CONFIRMEDsmeserver-baseconsole backup does not cope well with multiple removable devices available [8b7]
7129CONFIRMEDsmeserver-proftpd"proftpd: pam_env(ftp:setcred): Unable to open config file: /etc/security/pam_env.conf: No such file or directory" in "/var/log/secure"
7742CONFIRMEDsmeserver-dovecotIMAP session continues after disable IMAP in server-manager
7804CONFIRMEDsmeserver-baseOld name cannot be removed in DNS panel after server name is changed after updating e-smith-base to version 5.2.0-79.el5.sme
7805CONFIRMEDsmeserver-baseAdditional old name cannot be removed in DNS panel after updating e-smith-base to version 5.2.0-79.el5.sme
7840CONFIRMEDsmeserver-baseCannot exit from console on tty1 when console boot set to auto mode
7891CONFIRMEDsmeserver-qpsmtpdEmail - Block Executable Content false positives when signature found in the middle of a file
8008CONFIRMEDsmeserver-apachedeclare unixgroup in httpd.conf
8074CONFIRMEDsmeserver-emailSMTP to ISP Authentication timeout problem
8192CONFIRMEDsmeserver-baseMove dmount() to backup.pm
8271CONFIRMEDsmeserver-backupBackup - selective restore fails to display files and directories on large backups
8304CONFIRMEDsmeserver-baseConsole display slightly corrupted - black borders missing on two sides. [sme9b4]
8420CONFIRMEDsmeserver-baseLocal Networks - Delete Form - "Abbrechen" Button does not work correct
8945CONFIRMEDsmeserver-managerNFR: present option to set forward or adjust wording on Locked account screen
9058CONFIRMEDsmeserver-sambaOplock break failed for file USER.V5/NTUSER.DAT
9273CONFIRMEDsmeserver-spamassassinTextCat spamassassin plugin not loaded in the correct file
9426CONFIRMEDsmeserver-basewarning in messages logs and on screen when running ippp
9431CONFIRMEDsmeserver-baseerror running bootstrap-console
9656CONFIRMEDsmeserver-qpsmtpdReturn 4XX in case of DNS timeout while fetching dkim policies
9696CONFIRMED---update link http://www.contribs.org/development/
9805CONFIRMEDsmeserver-qpsmtpdFailure in DMARC report sending overnight
9906CONFIRMEDsmeserver-qpsmtpdRejected DMARC emails are tried every night, and never deleted?
10090CONFIRMEDsmeserver-emailmodify SM email panel wording to make spamassassin setting clearer
10103CONFIRMEDperl-Mail-DMARCDMARC sql error in qpsmtpd log
10233CONFIRMEDsmeserver-backuprestore from console will not restore mysql db
10285CONFIRMEDsmeserver-basePrevent entering invalid netmask
10497CONFIRMEDqpsmtpdqpsmtpd plugin typo in HELO log report
10550CONFIRMEDsmeserver-libNFR password generator
10570CONFIRMEDsmeserver-baseremove key StatusReports from config db
10643CONFIRMED---Error: IP cannot be server IP or Gateway IP.
10778CONFIRMEDsmeserver-qpsmtpd554 Message not allowed - [299] on yahoo server after enabling disclaimer
10835CONFIRMEDsmeserver-devtools.gitignore...
10845CONFIRMEDsmeserver-basepost-upgrade : Use of uninitialized value $nt_hash in string eq at /etc/e-smith/events/post-upgrade/S15user-lock-passwd
10953CONFIRMEDanacondadisable and hide addons in gui install
10977CONFIRMEDsmeserver-managerMake remoteaccess.pm also validate the subnet octets - make change for Server-Manager2
11085CONFIRMEDsmeserver-certificatesimprove integration of certificate with dehydrated using a dedicated domain
11235CONFIRMED---config memory / number convert sanitizer
11271CONFIRMEDsmeserver-mysqlChanging host.domain does not update Host in mysql database
11400CONFIRMEDsmeserver-phpease php change for contribs
11419CONFIRMEDsmeserver-radiusdremove pptpd references
11427CONFIRMEDsmeserver-phpallow set timeout
11444CONFIRMEDsmeserver-phpibay customisation: merge SSL option
11534CONFIRMEDsmeserver-radiusddifference between domain events
11540CONFIRMEDperl-Apache-AuthTktcookie without SameSite property
11560CONFIRMEDsmeserver-grubupdate-grub action runt by local on every reboot
11614CONFIRMEDsmeserver-certificatesNFR : check if custom cert and key are related and default to self signed if not
11615CONFIRMEDsmeserver-apacheNFR : httpd check if custom cert and key are related and default to self signed if not
11616CONFIRMEDsmeserver-proftpdNFR : proftpd check if custom cert and key are related and default to self signed if not
11689CONFIRMEDsmeserver-baseAllow comment for Remote Access panel, Remote Management table
11797CONFIRMEDperl-Email-SenderFirst Import to SME perl-Email-Sender-1.300036
11810CONFIRMEDsmeserver-managerLicense panel is left truncated, does not flow.
11884CONFIRMEDsmeserver-backupdesync of /etc/shadow - /etc/passwd /etc/group /etc/gshadow
11900CONFIRMEDsmeserver-mysqlcheck use of /sbin/e-smith/mysql-preload
11935CONFIRMED---oauth soon mandatory to fetch from gmail accounts
12099CONFIRMEDsmeserver-opensshIncrease MaxAuthTries for sshd
12110CONFIRMEDsmeserver-manageruntainting printers server-manager2
12156CONFIRMEDsmeserver-backuplog user to remove as they have no more use and missing their home
12270CONFIRMEDsmeserver-roundcubeNFR: Allow the specification of the host for the imap mail
12302CONFIRMEDsmeserver-phpNFR allow admin customization of ibays php fpm pool
12312CONFIRMEDsmeserver-clamavExtraneous database update values in clamav and freshclam
12320CONFIRMEDsmeserver-ibaysAdd functions to e-smith-ibays for webapps
12321CONFIRMEDsmeserver-ibaysCreate a new action to set permissions for an ibay based on dbase parameters and pre-set settings
12322CONFIRMEDsmeserver-ibaysBreakout setting ownership/permissions for ./files and ./html into a separate action
12377CONFIRMEDsmeserver-mockBogusDateBot.sh not handling multiple spaces within data
12433CONFIRMEDsmeserver-backupupon restore keep user id entry from supported services
12446CONFIRMEDsmeserver-managerWelcome screen - After login timeout - fails to show translated message
12513CONFIRMEDipsvdevaluate to retire ipsvd (required by smesevrer-qpsmtpd and smeserver-tftp-server)
12566CONFIRMEDdaemontoolsseek alternative to daemontools-encore 1.10-2 / daemontools 0.76
12578CONFIRMEDmultiple-packagesMake sure all SMEServer packages that we re-build reference the correct license.
12580CONFIRMED---Update any other reference to e-smith-.*-update to smeserver
12587CONFIRMEDsmeserver-roundcubecomposer installs skins in plugins folder
12604CONFIRMED---audit error augenrules[730]: failure 1
12667CONFIRMEDsmeserver-managerWorkstation restore from a removeable device fails
12692CONFIRMEDsmeserver-baseuse same wording for user action script
12696CONFIRMEDsmeserver-managerUncaught File 'Roboto-Regular.ttf' not found in virtual file system
12699CONFIRMEDsmeserver-managerSM2 Re-configure and Reboot not translated
12704CONFIRMEDsmeserver-localeHebrew translation only has "Date and Time" panel translated.
12713CONFIRMEDsmeserver-localeUpdate smeserver-manager.locale with po files (for weblate import)
12716CONFIRMEDsmeserver-updatealert after EOL if upstream release is not up to date
12728CONFIRMEDsmeserver-updateWarning for signal-event post-upgrade; signal-event reboot scrolls off screen.
12734CONFIRMEDsmeserver-mysqlMariaDB config setting table_definition_cache
12752CONFIRMEDsmeserver-managerNFR Server-manager - Add DHCP Wake On LAN links in hostnames panel
12768CONFIRMEDsmeserver-baseuserdel: user is currently used by process
12772CONFIRMEDsmeserver-libMove network functions from util.pm to util/network.pm
12862CONFIRMEDmini-qmailCleanup qmail users
12879CONFIRMEDsmeserver-dovecotNFR define default folder
12903CONFIRMEDsmeserver-managerThe jDatatable tables do not reflect the current locale in terms of language etc. Only show English
12904CONFIRMEDsmeserver-managerNFR paste ssh key in smanager Remote Access Panel
12911CONFIRMEDanacondapatch anaconda to change default partitionning
Warnings were generated during the execution of function
  1. Report truncated - count greater than max allowed 101 > 100


Important.png Note:
Bugs needing verification are shown here Verification_Queue



Verifications

IDPackageSummary (26 tasks)
9844smeserver-managerUser-password gives misleading error on entering same password
11708smeserver-managerCSRF security check should fully protect smeserver-manager
12677smeserver-baseadd support for external VLAN
12678smeserver-baserework pppoe for kernel space rather than use rspace
13074smeserver-base/usr/sbin/pppd: /usr/lib64/pppd/2.4.5/rp-pppoe.so: cannot open shared object file
13130smeserver-basepppoe fails to recconect after update: interface or tty missing
13307smeserver-managerUpdate to email settings for peer port mean't I lost my 3rd party mail server hostname
13449smeserver-managerSet CSS so that fields in a form extend to the right with a max of 50%, but auto sized within that.
13505smeserver-updatesmeserver-update: remove old server-manager panels
13592smeserver-certificatesLetsencrypt fails to create genuine cert when test certs have been generated
13634smeserver-managerdnf panel : detect if something is already running and display it
13652smeserver-managerBackup.pm controller does load directories to backup only at smanager start
13653smeserver-libservicecontrole should superseed to reload-or-restart any restart smanager
13681smeserver-managerpm files are not updated when we add new lex files translation
13684smeserver-baseencoding issue in /etc/e-smith/events/actions/user-modify-unix and /etc/e-smith/events/actions/user-create-unix
13686smeserver-managerRe-factor any set of tests where the subsequent test is still run when the previous one has failed
13689smeserver-managermy ($notif, $modul) = ; Does NOT intialise BOTH variables
13691smeserver-managerScan of Controller files found a few typos etc
13701smeserver-libCannot add user to ldap
13704smeserver-ldapmigrate missing values
13705smeserver-managerOverall bug to document changes needed to accomodate a new translation system
13711smeserver-manager-localeMake install remove smeserver-manager-locale-<langCode> packages when installing the new smeserver-manager-locale
13713smeserver-managerDNF panel start button hit fails with no CSRF token found
13714smeserver-managerWhen login timeout expires, arrange that the current panel is re-entered once re-login is successfull
13716smeserver-managerKeeping both the AuthTKT timeout and the smanager[Timeout} properties is a potential exploit
13718smeserver-certificatesExtra chars in Letsencrypt menu entry - Need perl module Locale-Maketext-Lexicon


Verified

IDPackageSummary (38 tasks)
12218smeserver-baseself-signed certificate renews every 24hrs with ' (apostrophe) in ldap field
12428smeserver-managerSM2 Login button does not highlight when you press it. - default Theme
12669smeserver-managerAfter using dnf to update and reboot, unable to login to SM1
12951smeserver-managerMail log analysis panel needs re-write for Postfix.
12989smeserver-managerWorkstation Restore when reboot is selected when offered SM2 errros to a Proxy Error screen and fails to reboot
13450smeserver-manageruser password panel - after an error password description reverts to lex string
13488smeserver-qpsmtpdallow enabling only private authentication for qpsmtpd / port 25
13574smeserver-managerNutUPS - Misssing entry in lex file
13581smeserver-certificatesLetsencrypt check&enable stops parsing at dash
13583smeserver-certificatesRevert Cert to self signed fails when called from SM2 panel
13586smeserver-managerViewlogfiles horizontal scroll bar is only visible at the bottom
13588smeserver-certificatesLE panel unresponsive without internet
13600smeserver-postfixSyntax errors in postfix files
13604smeserver-dovecotAdminIsMaster not working when SharedMailbox and ACL is also enabled
13613smeserver-mysqlmariadb-initialize should not test on /var/lib/mysql/mysql/user.frm
13615smeserver-certificatesgetmyip not overriden by letsencrypt{ExternalIP} set
13619smeserver-opensshWARNING: UNPROTECTED PRIVATE KEY FILE!
13620smeserver-managerChange admin password in Smanager throws an error
13636smeserver-nutUPSnut french
13639smeserver-managerMake sure all calls to the Accounts DB routines include the UTF8
13658smeserver-localeneed to translate FRAMES_SMANAGER
13659smeserver-managerRemote Management multi delete fails
13661smeserver-managerlocalize "please wait" on the submit buttons
13663smeserver-manager/usr/share/smanager/lib/SrvMngr/Controller/*.pm using non utf8 db
13665smeserver-certificatessmeserver-certificates still missing UTF8 in DB opening calls
13675smeserver-managerAdding domain with wide chars makes the self signed certificate unacceptable to Chromium.
13676smeserver-managerQuota panel:"Can't locate object method "localise" Error message when opening quota panel
13679smeserver-managernot redirect to current panel after authorization check
13680smeserver-managerincrease timeout before auto logout
13682smeserver-managerWide character should be refused from username/group/ibay (but accepted in description/firstname/lastname..)
13687smeserver-spamassassinwbl from and to lists
13690smeserver-managerChange e-mail access settings POP3 changes not being accepted on save remains as Enabled for local access only
13692smeserver-managerwhen creating or modifying user, the check for duplicate pseudonym does not lowercase the first and last names.
13695smeserver-managerdatetime panel: Time server test call needs csrf token
13696smeserver-managerEmail settings panel: DB Settings for email reception not set correctly
13697smeserver-libcreating or modifying user error Wide character in getpwnam at /usr/share/perl5/vendor_perl/esmith/AccountsDB.pm line 492.
13702smeserver-managerldap directory /useraccount : company compartment city and phone should be mandatory
13719smeserver-updateNeed perl-YAML module enabled

Closed

IDPackageSummary (768 tasks)
131smeserver-apache[ 1323823 ] RSA server certificate CommonName (CN) does NOT match...
931smeserver-proftpdNFR: ftp Anonymous should be disabled by default
2269smeserver-apacheLoad apache mod_dav module by default
5382smeserver-baseHostnames/addresses panel doesn't reject same IP with different mac
6278smeserver-managerUpdate server-manager to current web standards and to conform to CSP rules
6453smeserver-baseremove use_authtok from pam config when ldap auth is enabled
6510smeserver-qpsmtpdAllow port 587 to be used as mail submission port (ESMTP with authentication)
6819smeserver-packetfilterPort 25 closed after Server gateway switched to server, then back to gateway
7463e-smith-managerHeadingWeight Wrong in Server Panel navigation scripts
7490smeserver-certificatesSSL-certificate panel
7819perl-MojoliciousNew Server-Manager Framework, Mojolicious
7914?smeserver-proftpdCorrect proftpd.conf template(40IBayAccess).
7915smeserver-proftpdNew ibay's directory loses SGID flag then created via ftp.
7946?qmailqmail shoud ignore CNAME resolve failures
8185smeserver-certificatesProvide server-manager GUI for generating a CSR, and for uploading a signed certificate set.
8207smeserver-qmailError 454+451 in qmail log while trying to send mail trough ISP server
8268smeserver-baseRemove primary (all lower case) from defaults and accounts database
8275smeserver-libno console page uses whiptail
8309smeserver-managerAdd ipt_recent sshd autoblocking to e-smith-openssh - additional note in server-manager
8376smeserver-proftpdproftpd: Can I disable Anonymous logins
8477smeserver-managersmtp-auth-proxy PeerPort should be configurable
8676smeserver-certificatesIntegration of EFF free certificates
9196smeserver-certificatesServer manager panel for the letsencrypt
9492smeserver-qpsmtpdRemove unused config for qmail-smtpd
9566e-smith-managerServer-Manager uses unsafe-inline scripts/stylesheets <-> Strong Content-Security-Policy on VirtualHosts
9567smeserver-apacheTemplate for Content-Security-Policy on VirtualHosts
9586---Move Mitel copyright notices to copyright and licenses page
9751sambaRebuild Samba-4.18.6-3 Upstream Package with Domain Controller Support
10307smeserver-emailJunkMail - some messages end ups in JunkMail folder despite "Sort spam into junkman folder" = Disabled
10336---plymouth screen on first boot display linux centos 7
10440smeserver-postfixemail to pseudonyms pointing to another pseudonym fails when they are another full email
10725smeserver-managererror logged on backup panel
10738qpsmtpdqpsmtpd logging corruption
10779smeserver-spamassassinqpsmtpd "Unable to scan for viruses" after creating custom rules for local.cf
10847smeserver-ldapibay-modify failed to modify entry
10933qpsmtpdTLS error give an empty line
10935smeserver-dovecotdovecot should use ssl_dh=</path/to/dh.pem instead of ssl_dh_parameters_length
10954anacondacreate and fill help KoozaliPlaceholder.html and KoozaliPlaceholderWithLinks.html
10976smeserver-managerMake localnetworks.pm validate the subnet octets for Server- manager2
11185smeserver-managerNew version for smeserver-manager
11367---change type from service to configuration
11380smeserver-devtoolsbrb and python for genfilelist
11416smeserver-testremove pptpd references
11417smeserver-libremove pptpd references
11418smeserver-hostsremove pptpd references
11476smeserver-phpEdit spelling and confirm db prop name ibay.conf and 20Horde
11478smeserver-audittoolsConfiguration report (under Server Manager/Report a bug) Includes some parts of the standard install
11671smeserver-qpsmtpdFiles and folders in /var/spool/qpsmtpd are not being cleaned up
11733smeserver-dovecotDovecot quota-fs error
11772smeserver-basessl.pm does not handle elliptic curve certificates
11780smeserver-managerAdd in dummy classes to div in each ep file for future themes
11793smeserver-managerFor smeserver-manager - add module class to div id="module"
11802qpsmtpdUpdate qpsmtpd to latest from git
11809smeserver-managerLack of a space after full stop and comma in English version of Server Manager2 panel descriptions in some places.
11815smeserver-managerBring Group add and update panels into line with others
11821smeserver-managerMail log file analysis shows blank
11822smeserver-managerIn Review Configuration virtual domains not aligned.
11823smeserver-managerIn Review Configuration - IP address not show correctly for Server Gateway
11824smeserver-managerUser and Hostnames list does not act responsivly as window is made smaller
11825smeserver-managerReview configuration panel - In Server-Gateway, External IP and DHCP range not properly displayed
11830smeserver-managerUpdate Datetime and reboot ep files to help AdminLTE
11846smeserver-managerWarning from Browser when jquery loaded - unable to find .map file
11856smeserver-mysqlUpgrade MariaDB to 10.x
11906smeserver-manager-AdminLTESort out spacing in menu when small fonts selected
12111smeserver-manageruntainting server-manager2
12113smeserver-updateupdate smeserver.py plugin to be dnf compatible
12114smeserver-updateupdate yum to dnf and modules
12144smeserver-dovecotUpdating dovecot-extras overwrites existing sharedmailbox.db
12149smeserver-baseerror opening /var/log/php/php/error.log
12150smeserver-dovecotNFR: use INDEXPVT instead of INDEX for shared mailboxes (per-user \Seen flags)
12180---IPv6 Support
12211smeserver-libtemplate-begin-ini should be in e-smith-lib not smeserver-php
12245smeserver-manager-AdminLTEMenu formatting with Server Manager 2 and AdminLTE
12265smeserver-dovecotupdate sieve /spam script
12280---no matching host key type found. Their offer: ssh-dss,ssh-rsa
12338---Bug to cover the move from CVS to Git
12359---Rename all baseos e-smith* packages to smeserver*
12360smeserver-apacheChange all references to httpd-e-smith to httpd-smeserver
12369smeserverRemove e-smith package?
12382smeserver-formmagickpassword requirement is different in panel and from samba
12383smeserver-libincrease password size requirement from 6 to 12-14 and make it configurable
12384smeserver-liballow more granularity in the content of password
12387smeserver-managerServer Manager 2 should open unconverted contribs/panels in the current page, possibly within an iframe
12396cvmobsolete cvm-unix
12400smeserver-manageradapt last update for yum panel to smanager
12423smeserver-mockbuild proof of concept
12424---list of rpm in smeos for 10 that will probably need build for sme 11
12430smeserver-phpdefault setting for serialize_precision in PHP 7.1 and higher is incorrect
12442smeserver-managerDefault theme for SM2 submit button does not reflect hover or click
12444smeserver-managerProxy Error following software update
12451smeserver-qpsmtpdseparate qpsmtpd sqpsmtpd and uqpsmtpd configurations
12454smeserver-proftpdMissing PassivePorts fragment
12457smeserver-managerExperiment with making tables sortable and filterable and paged - using jquery.
12458smeserver-managerUpdate SM2 to use jquery plugin dataTable for tables
12459smeserver-manager-jqueryCreate rpm - smeserver-manager-jquery
12464smeserver-managerServer Manager 2 needs to save and restore menu organisation
12465smeserver-manager-jqueryUpdate smeserver-manager-jsquery to fix left alignment of tables
12466smeserver-managerAdd export buttons to tables in SM2 default theme.
12467smeserver-manager-jqueryIcon not shown when second page selected on dataTable table
12471smeserver-managerSM2 email-filtering spam settings display or change incorrectly
Warnings were generated during the execution of function
  1. Report truncated - count greater than max allowed 101 > 100

Recent documentation changes

Related changes:
No changes during the given period match these criteria.